Excel количество значений в ячейках

Как выполнить подсчёт ячеек со значением

Здравствуйте, дорогие читатели.

Перед началом данной темы я бы хотел вам посоветовать отличный обучающий продукт по теме экселя, по названием « Неизвестный Excel » , там всё качественно и понятно изложено. Рекомендую.

Ну а теперь вернёмся к теме.

Вы наверняка являетесь представителем одной из профессий, в которой не обойтись без программы эксель. Ведь она позволяет вести подсчеты, составлять списки, таблицы и диаграммы, заполнять ежедневники и решать многие другие задачи, связанные с цифрами.

Однако не все, кто работает с этим приложением, знает его полную функциональность и умеет ее применять на практике. Вы один из них? Тогда вы обратились по адресу. В частности, сегодня мы разберем, как в excel подсчитать количество ячеек со значением. Есть несколько способов, как это сделать. Они зависят от того, какое именно содержимое вам нужно посчитать. Разберем самые популярные из них.

Самый быстрый способ

Наиболее простым, но в то же время поверхностным, является способ подсчета элементов в строке состояния. Их численность выводится в самой нижней панели открытого окна.

Если вы хотите задать определенные несложные параметры подсчетам, откройте настройки строки состояния. Это можно сделать, щелкнув правой кнопкой мыши по ней. В появившемся окне обратите внимание на ту часть, где написано «Среднее», «Количество», «Количество чисел», «Минимум», «Максимум» и «Сумма».

Выберите нужный параметр и узнайте больше о том, что содержит ваша таблица.

Подсчет ячеек в строках и столбцах

Существует два способа, позволяющие узнать количество секций. Первый — дает возможность посчитать их по строкам в выделенном диапазоне. Для этого необходимо ввести формулу =ЧСТРОК(массив) в соответствующее поле. В данном случае будут подсчитаны все клетки, а не только те, в которых содержатся цифры или текст.

Второй вариант — =ЧИСЛСТОЛБ(массив) — работает по аналогии с предыдущей, но считает сумму секций в столбце.

Считаем числа и значения

Я расскажу вам о трех полезных вещах, помогающих в работе с программой.

  1. Сколько чисел находится в массиве, можно рассчитать с помощью формулы СЧЁТ(значение1;значение2;…). Она учитывает только те элементы, которые включают в себя цифры.То есть если в некоторых из них будет прописан текст, они будут пропущены, в то время как даты и время берутся во внимание. В данной ситуации не обязательно задавать параметры по порядку: можно написать, к примеру, =СЧЁТ(А1:С3;В4:С7;…).
  2. Другая статистическая функция — СЧЕТЗ — подсчитает вам непустые клетки в диапазоне, то есть те, которые содержат буквы, числа, даты, время и даже логические значения ЛОЖЬ и ИСТИНА.
  3. Обратное действие выполняет формула, показывающая численность незаполненных секций — СЧИТАТЬПУСТОТЫ(массив). Она применяется только к непрерывным выделенным областям.

Ставим экселю условия

Когда нужно подсчитать элементы с определённым значением, то есть соответствующие какому-то формату, применяется функция СЧЁТЕСЛИ(массив;критерий). Чтобы вам было понятнее, следует разобраться в терминах.

Массивом называется диапазон элементов, среди которых ведется учет. Это может быть только прямоугольная непрерывная совокупность смежных клеток. Критерием считается как раз таки то условие, согласно которому выполняется отбор. Если оно содержит текст или цифры со знаками сравнения, мы его берем в кавычки. Когда условие приравнивается просто к числу, кавычки не нужны.

Разбираемся в критериях

  • «>0» — считаются ячейки с числами от нуля и выше;
  • «Товар» — подсчитываются секции, содержащие это слово;
  • 15 — вы получаете сумму элементов с данной цифрой.

Для большей ясности приведу развернутый пример.

Чтобы посчитать ячейки в зоне от А1 до С2, величина которых больше прописанной в А5, в строке формул необходимо написать =СЧЕТЕСЛИ(А1:С2;«>»&А5).

Задачи на логику

Хотите задать экселю логические параметры? Воспользуйтесь групповыми символами * и ?. Первый будет обозначать любое количество произвольных символов, а второй — только один.

К примеру, вам нужно знать, сколько имеет электронная таблица клеток с буквой Т без учета регистра. Задаем комбинацию =СЧЕТЕСЛИ(А1:D6;«Т*»). Другой пример: хотите знать численность ячеек, содержащих только 3 символа (любых) в том же диапазоне. Тогда пишем =СЧЕТЕСЛИ(А1:D6;«. »).

Средние значения и множественные формулы

В качестве условия может быть задана даже формула. Желаете узнать, сколько у вас секций, содержимое которых превышают среднее в определенном диапазоне? Тогда вам следует записать в строке формул следующую комбинацию =СЧЕТЕСЛИ(А1:Е4;«>»&СРЗНАЧ(А1:Е4)).

Если вам нужно сосчитать количество заполненных ячеек по двум и более параметрам, воспользуйтесь функцией СЧЕТЕСЛИМН. К примеру, вы ищите секций с данными больше 10, но меньше 70. Вы пишете =СЧЕТЕСЛИМН(А1:Е4;«>10»;А1:Е4;« Этой статьей стоит поделиться

Источник: profi-user.ru

Посчитать количество значений в ячейке Excel

Добрый день, уважаемый читатель!

Эту статью я хочу посвятить повторам тех значений, которые встречаются в вашей таблице, то есть мы научимся как подсчитывать повторения в Excel. Данная возможность будет полезной при подсчёте одинаковых значений в необходимом диапазоне, это поможет когда с большого массива вам нужно сгруппировать, например, сколько сотрудников сделало чеков, сколько раз работали с тем или иным поставщиком и многое другое.

Для начала рассмотрим, как выглядят столбики с данными, повторения в которых, мы собственно и будем считать. К примеру, возьмём список сотрудников, которые совершают продажи.

Теперь можно посчитать, сколько раз сотрудник производил продажи, то есть попросту считаем сколько повторений его фамилии в столбике. Это возможно произвести несколькими способами:

  1. С помощью функции СЧЁТЕСЛИ;
  2. С помощью функции СЧЁТЕСЛИМН;
  3. С помощью функции ДЛСТР;
  4. С помощью функций VBA.

Используя функцию СЧЁТЕСЛИ

В Excel произвести такой подсчёт чрезвычайно просто, достаточно задействовать функцию СЧЁТЕСЛИ и она за несколько секундок всё за вас сделает. В нашем случае формула будет следующего вида:

=СЧЁТЕСЛИ($B$2:$B$11;B15)

В первом аргументе «диапазон» $B$2:$B$11, указываем тот диапазон ячеек, в котором и будет производиться подсчёт повторяющихся данных. Важно! Указывать случайный диапазон данных недопустимо. Его особенностью является то, что он может быть только диапазоном ячеек или ссылкой на определённую ячейку.

Вторым аргументом «критерий» ставим указание на ячейку, по которому будет производиться подсчёт аналогичных данных. Если он один вы можете его прописать вручную как текстовое слово и вместо адреса ячейки «B15» указать «Нагаев А.В.», результат будет аналогичным, но только в одном конкретном случае, возможность автоматизации таблицы тогда значительно сократится.

Дополнительная информация! Кроме прямого указания поиска данных, функция СЧЁТЕСЛИ умеет работать с символами подстановки. Таких знаков используют двух видов «?» и «*„, применять их возможно только при работе с текстовыми символами. Знак “*» позволяет заменить абсолютно любое количество значений, а Знак «?» производит замену только одного символа.

Читайте также:  Excel выравнивание ячеек по содержимому

Для работы с числовыми значениями необходимо применять знаки операторов сравнения: «>», « » и «=». К примеру, для подсчёта числовых значений больше «нуля» прописывайте «>0», а для подсчёта непустых ячеек нужен указать «<>».

Используем функцию СЧЁТЕСЛИМН

Когда у вас возникает необходимость подсчитывать повторения в Excel, но уже по нескольким критериям, тогда нужно работать с функцией СЧЁТЕСЛИМН, которая легко и просто сможет это выполнить.

В моём примере я добавлю категорию продаж по городам и используя формулы соберу необходимые мне повторы:

=СЧЁТЕСЛИМН($B$2:$B$11;B14;$C$2:$C$11;C14)

Замечу, что орфография функции абсолютно аналогична предыдущей функции СЧЁТЕСЛИ, разница состоит только в их количестве. В нашем примере их два, но функция умеет работать и со 127 диапазонами.

Работаем с функцией ДЛСТР

Теперь давайте рассмотрим ситуацию, когда не всё так просто и упорядоченно, когда информация сбита в одну ячейку, к примеру, «Нагаев Гаврош Каропачёв Козубенко Нагаев Гаврош Козубенко Нагаев Нагаев». В этом случае статистические функции нам не помогут, необходимо считать символы и сверять повторы значений с указанным эталоном. Для этих целей есть много иных полезных функций, используя которые это можно провернуть достаточно просто:

=(ДЛСТР($B$2) -ДЛСТР(ПОДСТАВИТЬ($B$2;B5;«»)))/ДЛСТР(B5)

Итак, используя функцию ДЛСТР, мы считаем, сколько же символов содержится в ячейке «$B$2» и «B5», результат будет «71». А потом с помощью функции ПОДСТАВИТЬ производим замену текущего значения на «пусто», получаем результат «47». Следующим действием отнимаем от общего количества символов наш остаток «71-47=24» и делим на количество символов в одном значении «24/6=4», как результат получаем сколько раз в строке, встречается необходимый результат… Ответ: 4. (Это результат рассматривая только первую строку поиска).

С помощью функций VBA

Последний рассматриваемый вариант, это подсчёт количества повторений с помощью, созданной в VBA функции. Функции я не писал, а просто предлагаю вам найденный ранее вариант, чтобы упростить вашу работу.

Для начала вам нужно запустить редактор макросов VBA и вставить новый модуль с помощью команд «Insert» — «Module».

В созданное окно модуля вы вставляете код функции:

После всего этого вызываете «Диспетчер функций» в панели управления или с помощью горячих клавиш Ctrl+F3 и в категории «Определённые пользователем» у вас появляется новая необходимая функция.

Используем функцию на ячейке стандартным образом с помощью формулы:

=GetRepeat ($B$2;B8), где:


Источник: officeassist.ru

Как подсчитать количество повторений

В этой статье я хочу рассказать, как можно подсчитать количество повторений какого-либо значения в таблице или в ячейке. Начнем по порядку. Имеется таблица:

И необходимо подсчитать количество повторений каждого наименования:

Как ни странно, но сделать это весьма просто: в Excel имеется функция – СЧЁТЕСЛИ, при помощи которой все это сделать можно буквально за секунды. Если количество повторений каждого наименования необходимо вывести в столбец В таблицы, а сами наименования расположены в столбце А:
=СЧЁТЕСЛИ( $A$2:$A$30 ; A2 )
Диапазон ( $A$2:$A$30 ) – указываются ячейки диапазона, в которых записаны значения, количество которых необходимо подсчитать. Главная особенность: данный аргумент может быть исключительно ссылкой на ячейку или диапазон ячеек. Недопустимо указывать произвольный массив значений.
Критерий ( A2 ) – указывается ссылка на ячейку или непосредственно значение для подсчета. Т.е. можно указать и так: =СЧЁТЕСЛИ( $A$2:$A$30 ;”Яблоко”) . Помимо этого можно применять символы подстановки: ? и *. Т.е. указав в качестве Критерия “*банан*” можно подсчитать количество ячеек, в которых встречается слово “банан” (банановый, банан, бананы, банановый сок, сто бананов, три банана и орех и т.п.). А указав “банан*” — значения, начинающиеся на “банан” (бананы, банановый сок, банановая роща и т.п.). “?” — заменяет лишь один символ, т.е. указав “бан?н” можно подсчитать строки и со значением “банан” и со значением “банон” и т.д. Если в качестве критерия указать =СЧЁТЕСЛИ( $A$2:$A$30 ;”*”) , то будут подсчитаны все текстовые значения. Числовые значения при этом игнорируются. Данные подстановочные символы (* и ?) не получится применить к числовым значениям – исключительно к тексту. Т.е. если если указать в качестве критерия “12*”, то числа 1234, 123, 120 и т.п. не будут подсчитаны. Для подсчета числовых значений следует применять операторы сравнения: =СЧЁТЕСЛИ( $A$2:$A$30 ;”>12″)

Подсчитать числа, которые больше нуля: =СЧЁТЕСЛИ( $A$2:$A$30 ;”>0″)
Подсчитать количество непустых ячеек: =СЧЁТЕСЛИ( $A$2:$A$30 ;”<>“)

Как видно из второго рисунка – там наименования не повторяются, хотя в таблице они все записаны вперемешку. Я не буду заострять на этом внимание – я уже описывал это в статье Как получить список уникальных(не повторяющихся) значений? и при необходимости можно воспользоваться любым описанным в ней методом.

Но. Бывают случаи, когда список расположен вовсе не в таблице, а в одной ячейке( $D$1 ):
Дыня Киви Груша Яблоко Дыня Груша Груша Арбуз Яблоко Банан Яблоко Яблоко Банан Яблоко Яблоко Дыня Дыня Киви Банан Дыня Арбуз Дыня Киви Яблоко Дыня Груша Яблоко Киви Арбуз
Здесь СЧЁТЕСЛИ точно не поможет. Но в Excel полно других функций и все можно сделать так же достаточно просто:
=(ДЛСТР( $D$1 )-ДЛСТР(ПОДСТАВИТЬ( $D$1 ; D3 ;””)))/ДЛСТР( D3 )
ДЛСТР – подсчитывает количество символов в указанной ячейке/строке( $D$1 , D3 )
ПОДСТАВИТЬ (текст; старый_текст; новый_текст) – заменяет в указанном тексте заданный символ на любое другое заданное значение. По умолчанию заменяет все повторы указанного символа. Именно это и положено в основу алгоритма. На примере значения Банан( D3 ) пошаговый разбор формулы:

  • при помощи функции ДЛСТР получаем количество символов в строке с исходным текстом( $D$1 ) =(170-ДЛСТР(ПОДСТАВИТЬ( $D$1 ; D3 ;””)))/ДЛСТР( D3 ) ;
  • при помощи функции ПОДСТАВИТЬ заменяем в строке с исходным текстом( $D$1 ) все значения Банан( D3 ) на пусто и при помощи ДЛСТР получаем количество символов строки после этой замены =(170-155)/ДЛСТР( D3 ) ;
  • вычитаем из общего количества символов количество символов в строке после замены и делим результат на количество символов в критерии =(170-155)/5 .

Получаем число 3. Что нам и требовалось.

И простая функция пользователя, которая так же подсчитывает повторения внутри ячейки:

Function GetRepeat(sTxt As String, sCntWord As String) GetRepeat = (Len(sTxt) – Len(Replace(sTxt, sCntWord, “”))) / Len(sCntWord) End Function

Чтобы правильно использовать приведенный код, необходимо сначала ознакомиться со статьей Что такое функция пользователя(UDF)?. Вкратце: скопировать текст кода выше, перейти в редактор VBA( Alt + F11 ) -создать стандартный модуль(InsertModule) и в него вставить скопированный текст. После чего функцию можно будет вызвать из Диспетчера функций( Ctrl + F3 ), отыскав её в категории Определенные пользователем (User Defined Functions) .
Синтаксис функции:
=GetRepeat( $D$1 ; D3 )
sTxt – текст, в котором подсчитываем кол-во вхождения.
sCntWord – текст для подсчета. Может быть символом или словом.

Читайте также:  Как в excel сделать выбор в ячейке

Tips_All_Count_Duplicate.xls (39,0 KiB, 9 485 скачиваний)

Статья помогла? Поделись ссылкой с друзьями!

Поиск по меткам

Добрый день.
Можете ли вы мне помочь?

Нужно посчитать количество повторений по столбцу рейс только в одной строке.
Рейс. Объем. Колич
повтор
1аб. 2 2
1ав. 3. 1
1 аб. 0.3. 2 (2нужно посчитать как 0)
2аг. 9. 2
2аг. 3. 2 (2нужно посчитать как 0)
2ав. 0.4. 1

Убрать дубликаты не могу, т.к удаляет всю строку, а значения в поле объем нужны для дальнейшего расчета. Упорядочить значения в столбце рейс тоже нельзя, т.к во всей исходной таблице есть объединенные ячейки, которые нельзя разбить.

Попробуйте задать вопрос в форуме , приложив пример файла с данными. По одному описанию у меня не получается понять задачу.

Источник: www.excel-vba.ru

Функция СЧЁТЕСЛИ и подсчет количества значения ячейки в Excel

Функция СЧЁТЕСЛИ в Excel используется для подсчета количества ячеек в рассматриваемом диапазоне, содержащиеся данные в которых соответствуют критерию, переданному в качестве второго аргумента данной функции, и возвращает соответствующее числовое значение.

Функция СЧЁТЕСЛИ может быть использована для анализа числовых значений, текстовых строк, дат и данных другого типа. С ее помощью можно определить количество неповторяющихся значений в диапазоне ячеек, а также число ячеек с данными, которые совпадают с указанным критерием лишь частично. Например, таблица Excel содержит столбец с ФИО клиентов. Для определения количества клиентов-однофамильцев с фамилией Иванов можно ввести функцию =СЧЁТЕСЛИ(A1:A300;”*Иванов*”). Символ «*» указывает на любое количество любых символов до и после подстроки «Иванов».

Примеры использования функции СЧЁТЕСЛИ в Excel

Пример 1. В таблице Excel содержатся данные о продажах товаров в магазине бытовой техники за день. Определить, какую часть от проданной продукции составляет техника фирмы Samsung.

Вид исходной таблицы данных:

Для расчета используем формулу:

  • C3:C17 – диапазон ячеек, содержащих названия фирм проданной техники;
  • “Samsung” – критерий поиска (точное совпадение);
  • A17 – ячейка, хранящая номер последней продажи, соответствующий общему числу продаж.

Доля проданной продукции техники фирмы Samsung в процентах составляет – 40%.

Подсчет количества определенного значения ячейки в Excel при условии

Пример 2. По итогам сдачи экзаменов необходимо составить таблицу, в которой содержатся данные о количестве студентов, сдавших предмет на 5, 4, 3 балла соответственно, а также тех, кто не сдал предмет.

Вид исходной таблицы:

Предварительно выделим ячейки E2:E5, введем приведенную ниже формулу:

  • B3:B19 – диапазон ячеек с оценками за экзамен;
  • D2:D5 – диапазон ячеек, содержащих критерии для подсчета числа совпадений.

В результате получим таблицу:

Статистический анализ посещаемости с помощью функции СЧЁТЕСЛИ в Excel

Пример 3. В таблице Excel хранятся данные о просмотрах страниц сайта за день пользователями. Определить число пользователей сайта за день, а также сколько раз за день на сайт заходили пользователи с логинами default и user_1.

Вид исходной таблицы:

Поскольку каждый пользователь имеет свой уникальный идентификатор в базе данных (Id), выполним расчет числа пользователей сайта за день по следующей формуле массива и для ее вычислений нажмем комбинацию клавиш Ctrl+Shift+Enter:

Выражение 1/СЧЁТЕСЛИ(A3:A20;A3:A20) возвращает массив дробных чисел 1/количество_вхождений, например, для пользователя с ником sam это значение равно 0,25 (4 вхождения). Общая сумма таких значений, вычисляемая функцией СУММ, соответствует количеству уникальных вхождений, то есть, числу пользователей на сайте. Полученное значение:

Для определения количества просмотренных страниц пользователями default и user_1 запишем формулу:

В результате расчета получим:

Особенности использования функции СЧЁТЕСЛИ в Excel

Функция имеет следующую синтаксическую запись:

=СЧЕТЕСЛИ( диапазон; критерий )

  • диапазон – обязательный аргумент, принимающий ссылку на одну либо несколько ячеек, в которых требуется определить число совпадений с указанным критерием.
  • критерий – условие, согласно которому выполняется расчет количества совпадений в рассматриваемом диапазоне. Условием могут являться логическое выражение, числовое значение, текстовая строка, значение типа Дата, ссылка на ячейку.
  1. При подсчете числа вхождений в диапазон в соответствии с двумя различными условиями, диапазон ячеек можно рассматривать как множество, содержащее два и более непересекающихся подмножеств. Например, в таблице «Мебель» необходимо найти количество столов и стульев. Для вычислений используем выражение =СЧЁТЕСЛИ(B3:B200;”*стол*”)+СЧЁТЕСЛИ(B3:B200;”*стул*”).
  2. Если в качестве критерия указана текстовая строка, следует учитывать, что регистр символов не имеет значения. Например, функция СЧЁТЕСЛИ(A1:A2;”Петров”) вернет значение 2, если в ячейках A1 и A2 записаны строки «петров» и «Петров» соответственно.
  3. Если в качестве аргумента критерий передана ссылка на пустую ячейку или пустая строка «», результат вычисления для любого диапазона ячеек будет числовое значение 0 (нуль).
  4. Функция может быть использована в качестве формулы массива, если требуется выполнить расчет числа ячеек с данными, удовлетворяющим сразу нескольким критериям. Данная особенность будет рассмотрена в одном из примеров.
  5. Рассматриваемая функция может быть использована для определения количества совпадений как по одному, так и сразу по нескольким критериям поиска. В последнем случае используют две и более функции СЧЁТЕСЛИ, возвращаемые результаты которых складывают или вычитают. Например, в ячейках A1:A10 хранится последовательность значений от 1 до 10. Для расчета количества ячеек с числами больше 3 и менее 8 необходимо выполнить следующие действия:
  • записать первую функцию СЧЁТЕСЛИ с критерием «>3»;
  • записать вторую функцию с критерием «>=8»;
  • определить разницу между возвращаемыми значениями =СЧЁТЕСЛИ(A1:10;”>3″)-СЧЁТЕСЛИ(A1:A10;”>=8″). То есть, вычесть из множества (3;+∞) подмножество [8;+∞).

Источник: exceltable.com

Подсчет значений с множественными критериями (Часть 1. Условие И) в EXCEL

Произведем подсчет строк, удовлетворяющих сразу двум критериям, которые образуют Условие И.

В качестве исходной таблицы возьмем таблицу с двумя столбцами: текстовым « Фрукты » и числовым « Количество на складе » (См. файл примера ).

Задача1

Рассмотрим задачу, когда критерии применяются к значениям из разных столбцов.

Найдем число партий товара с определенным Фруктом И с Количеством на складе не менее минимального (Условие И – условие при котором строка считается удовлетворяющей критерию, когда оба ее поля одновременно соответствуют критериям). Например, число партий персики ( ячейка D 2 ) с количеством ящиков на складе >=5 ( ячейка Е2 ) . Результат очевиден: 2. Для наглядности, строки в таблице, удовлетворяющие критериям, выделяются Условным форматированием с правилом =И($A2=$D$2;$B2>=$E$2)

Подсчет можно реализовать множеством формул, приведем несколько:

1. = СЧЁТЕСЛИМН(A2:A13;D2;B2:B13;”>=”&E2) Это решение является самым простым и понятным.

2. =СУММПРОИЗВ(–(A2:A13=D2);–(B2:B13>=E2)) Это решение сложнее, но позволяет понять работу функции СУММПРОИЗВ() , которая может быть полезна для подсчета с множественными критериями в других случаях.

Читайте также:  Зависимые ячейки в excel на другом листе

Разберем подробнее применение функции СУММПРОИЗВ() :

  • Результатом вычисления A2_A13=D2 является массив <ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ>Значение ИСТИНА соответствует персики . Результат можно увидеть, выделив A2_A13=D2 , а затем нажав клавишу F9 ;
  • Двойное отрицание (–) преобразует вышеуказанный массив в числовой:
  • Аналогично, второй массив возвращает <0:1:1:1:0:1:1:0:0:1:1:1>, где 0 соответствует значениям =5, поэтому второе значение в массиве =1 и т.д.
  • Далее, функция попарно перемножает элементы массивов и суммирует их. Получаем – 2.

3. Другим вариантом использования функции СУММПРОИЗВ() является формула =СУММПРОИЗВ((A2:A13=D2)*(B2:B13>=E2)) . Здесь, знак Умножения (*) эквивалентен Условию И.

4. Формула массива = СУММ((A2:A13=D2)*(B2:B13>=E2)) эквивалентна вышеупомянутой формуле =СУММПРОИЗВ((A2:A13=D2)*(B2:B13>=E2)) Единственное, после ее ввода нужно вместо ENTER нажать CTRL + SHIFT + ENTER

5. Формула массива = СЧЁТ(ЕСЛИ((A2:A13=D2)*(B2:B13>=E2);B2:B13)) представляет еще один вариант многокритериального подсчета значений.

6. Формула = БСЧЁТА(A1:B13;A1;D14:E15) требует предварительного создания таблицы с условиями. Заголовки этой таблицы должны в точности совпадать с заголовками исходной таблицы. Размещение условий в одной строке соответствует Условию И.

Здесь есть один трюк: в качестве второго аргумента функции БСЧЁТА() ( поле) нужно ввести ссылку на заголовок столбца с текстовыми значениями, т.к. БСЧЁТА() подсчитывает текстовые значения . В случае использования БСЧЁТ() нужно записать другую формулу =БСЧЁТ(A1:B13;B1;D14:E15) . Табличка с критериями не изменится.

Задача2

Рассмотрим задачу, когда критерии применяются к значениям из одного столбца.

Найдем число партий товара с Количеством на складе не менее минимального и не более максимального (Условие И – строка таблицы соответствует критерию, когда ее поле удовлетворяет обоим критериям одновременно).

Решение стоится аналогично предыдущей задачи. Например, с использованием функции СЧЁТЕСЛИМН() формула выглядит так (см. лист один столбец в файле примера ):

Альтернативное решение

Подсчитать количество строк, удовлетворяющим 2-м критериям (Условие И) можно без применения формул с помощью стандартного Автофильтра .

Установите автофильтр к столбцу Количество ящиков на складе , выделив заголовок столбца и нажав CTRL+SHIFT+L. Выберите числовой фильтр Между .

Убедитесь, что результат такой же как в задаче2 – т.е. будет отобрано 7 строк (см. строку состояния в нижней части окна).

Примечание : подсчет значений с множественными критерями также рассмотрен в статьях Подсчет значений с множественными критериями (Часть 2. Условие ИЛИ) , Часть3 , Часть4 .

Источник: excel2.ru

Как в Экселе посчитать количество ячеек

Посчитать количество ячеек в Эксель может потребоваться в различных случаях. В данной статье, мы и рассмотрим, как посчитать блоки с определенными значениями, пустые и если они попадают под заданные условия. Использовать для этого будем следующие функции: СЧЁТ, СЧЁТЕСЛИ, СЧЁТЕСЛИМН, СЧИТАТЬПУСТОТЫ.

Заполненных

Для начала, рассмотрим самый простой способ. Если Вам нужно посчитать количество заполненных блоков в Excel, выделите диапазон ячеек в документе – существуют различные способы, прочтите про них, перейдя по ссылке – и в «Строке состояния» обратите внимание на пункт «Количество» . Там будет написано количество непустых блоков: учитываются все с текстом и цифрами, а пустые – нет.

Если Вам нужно посчитать блоки в таблице, заполненные определенными значениями, и использовать это число в формулах для расчетов, то данный способ не подойдет, так как, данные в таблице могут периодически меняться. Поэтому перейдем к рассмотрению функций.

Где введены числа

Функция СЧЁТ – подсчитывает блоки, заполненные только числовыми значениями. Выделяем Н1 , ставим «=» , пишем функцию «СЧЁТ» . В качестве аргумента функции укажите нужный диапазон (F1:G10) . Если диапазонов несколько, разделите их «;» – (F1:G10;B3:C8) .

Всего заполнено 20 блоков. Тот, в котором записан текст, был не учтен, но посчитаны те, которые заполнены датой и временем.

С определенным текстом или значением

Функция СЧЁТЕСЛИ – позволяет рассчитать количество блоков, которые соответствуют заданному критерию. В качестве аргумента прописывается диапазон – В2:В13 , и через «;» указывается критерий – «>5» .

Например, есть таблица, в которой указано, сколько килограмм определенного товара было продано за день. Посчитаем, сколько товаров было продано весом больше 5 килограмм. Для этого нужно посчитать сколько блоков в столбце Вес, где значение больше пяти. Функция будет выглядеть следующим образом: =СЧЁТЕСЛИ(В2:В13;»>5″) . Она рассчитает количество блоков, содержимое в которых больше пяти.

Для того чтобы растянуть функцию на другие блоки, и скажем поменять условия, необходимо закрепить выбранный диапазон. Сделать Вы это сможете, используя абсолютные ссылки в Excel.

Функция также может рассчитать:

– количество ячеек с отрицательными значениями: =СЧЁТЕСЛИ(В2:В13;» ;
– количество блоков, содержимое в которых больше (меньше) чем в А10 (для примера): =СЧЁТЕСЛИ(В2:В13;»>»&A10) ;
– ячейки, значение в которых больше 0: =СЧЁТЕСЛИ(В2:В13;»>0″) ;
– непустые блоки из выделенного диапазона: =СЧЁТЕСЛИ(В2:В13;»<>») .

Применять функцию СЧЁТЕСЛИ можно и для расчета ячеек в Excel, содержащих текст. Например, рассчитаем, сколько в таблице фруктов. Выделим область и в качестве критерия укажем «фрукт». Будут посчитаны все блоки, с данным словом. Можно не писать текст, а просто выделить прямоугольник, который его содержит, например С2 .

Для формулы СЧЁТЕСЛИ регистр не имеет значения, будут подсчитаны ячейки содержащие текст «Фрукт» и «фрукт».

В качестве критерия также можно использовать специальные символы: «*» и «?» . Они применяются только к тексту.

Посчитаем сколько товаров начинается на букву А: «А*» . Если указать «абрикос*» , то учтутся все товары, которые начинаются с «абрикос»: абрикосовый сок, абрикосовое варенье, абрикосовый пирог.

Символом «?» можно заменить любую букву в слове. Написав в критерии «ф?укт» – учтутся слова фрукт, фуукт, фыукт.

Чтобы посчитать слова в ячейках, которые состоят из определенного количества букв, поставьте знаки вопросов подряд. Для подсчета товаров, в названии которых 5 букв, поставим в качестве критерия «. » .

Если в качестве критерия поставить звездочку, из выбранного диапазона будут посчитаны все блоки, содержащие текст.

С несколькими критериями

Функция СЧЁТЕСЛИМН используется в том случае, когда требуется указать несколько условий, максимальное их количество в Excel – 126. В качестве аргумента: задаем первый диапазон значений, и указываем условие, через «;» задаем второй диапазон, и пишем условие для него – =СЧЁТЕСЛИМН(B2:B13;»>5″;C2:C13;»фрукт») .

В первом диапазоне мы указали, чтобы вес был больше пяти килограмм, во втором выбрали, чтоб это были фрукты.

Пустых блоков

Функция СЧИТАТЬПУСТОТЫ рассчитает количество пустых ячеек в заданном диапазоне.

Посчитать в Экселе количество ячеек, которые содержат текст или числовые значения не так уж и сложно. Используйте для этого специальные функции, и задавайте условия. С их помощью можно посчитать как пустые блоки, так и те, где написаны определенные слова или буквы.

Источник: comp-profi.com