Countif excel как пользоваться

Функция СЧЁТЕСЛИ

В этом курсе:

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

С помощью статистической функции СЧЁТЕСЛИ можно подсчитать количество ячеек, отвечающих определенному условию (например, число клиентов в списке из определенного города).

Самая простая функция СЧЁТЕСЛИ означает следующее:

=СЧЁТЕСЛИ(где нужно искать;что нужно найти)

Группа ячеек, для которых нужно выполнить подсчет. Диапазон может содержать числа, массивы, именованный диапазон или ссылки на числа. Пустые и текстовые значения игнорируются.

Число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать.

Например, критерий может быть выражен как 32, “>32”, В4, “яблоки” или “32”.

В функции СЧЁТЕСЛИ используется только один критерий. Чтобы провести подсчет по нескольким условиям, воспользуйтесь функцией СЧЁТЕСЛИМН.

Примеры

Чтобы использовать эти примеры в Excel, скопируйте данные из приведенной ниже таблицы и вставьте их на новый лист в ячейку A1.

Количество ячеек, содержащих текст “яблоки” в ячейках А2–А5. Результат — 2.

Количество ячеек, содержащих текст “персики” (значение ячейки A4) в ячейках А2–А5. Результат — 1.

Количество ячеек, содержащих текст “яблоки” (значение ячейки A2) и “апельсины” (значение ячейки A3) в ячейках А2–А5. Результат — 3. В этой формуле для указания нескольких критериев, по одному критерию на выражение, функция СЧЁТЕСЛИ используется дважды. Также можно использовать функцию СЧЁТЕСЛИМН.

Количество ячеек со значением больше 55 в ячейках В2–В5. Результат — 2.

Количество ячеек со значением, большим или равным 32 и меньшим или равным 85, в ячейках В2–В5. Результат — 3.

Количество ячеек, содержащих любой текст, в ячейках А2–А5. Подстановочный знак “*” обозначает любое количество любых символов. Результат — 4.

Количество ячеек, строка в которых содержит ровно 7 знаков и заканчивается буквами “ки”, в диапазоне A2–A5. Подставочный знак “?” обозначает отдельный символ. Результат — 2.

Распространенные неполадки

Для длинных строк возвращается неправильное значение.

Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов.

Для работы с такими строками используйте функцию СЦЕПИТЬ или оператор сцепления &. Пример: =СЧЁТЕСЛИ(A2:A5;”длинная строка”&”еще одна длинная строка”).

Функция должна вернуть значение, но ничего не возвращает.

Аргумент критерий должен быть заключен в кавычки.

Формула СЧЁТЕСЛИ получает #VALUE! Ошибка при ссылке на другой лист.

Эта ошибка возникает при вычислении ячеек, когда в формуле содержится функция, которая ссылается на ячейки или диапазон в закрытой книге. Для работы этой функции необходимо, чтобы другая книга была открыта.

Рекомендации

Помните о том, что функция СЧЁТЕСЛИ не учитывает регистр символов в текстовых строках.

Критерий не чувствителен к регистру. Например, строкам “яблоки” и “ЯБЛОКИ” будут соответствовать одни и те же ячейки.

Использование подстановочных знаков

Подстановочные знаки: вопросительный знак (_Км_) и звездочка (*) — можно использовать в условиях. Вопросительный знак соответствует любому отдельно взятому символу. Звездочка — любой последовательности символов. Если требуется найти именно вопросительный знак или звездочку, следует ввести значок тильды (

) перед искомым символом.

Например, =СЧЁТЕСЛИ(A2:A5;”яблок?”) возвращает все вхождения слова “яблок” с любой буквой в конце.

Убедитесь, что данные не содержат ошибочных символов.

При подсчете текстовых значений убедитесь в том, что данные не содержат начальных или конечных пробелов, недопустимых прямых и изогнутых кавычек или непечатаемых символов. В этих случаях функция СЧЁТЕСЛИ может вернуть непредвиденное значение.

Для удобства используйте именованные диапазоны.

Функция СЧЁТЕСЛИ поддерживает именованные диапазоны в формулах (например, =СЧЁТЕСЛИ( фрукты;”>=32″)-СЧЁТЕСЛИ( фрукты;”>85″). Именованный диапазон может располагаться на текущем листе, другом листе этой же книги или листе другой книги. Чтобы одна книга могла ссылаться на другую, они обе должны быть открыты.

Примечание: С помощью функции СЧЁТЕСЛИ нельзя подсчитать количество ячеек с определенным фоном или цветом шрифта. Однако Excel поддерживает пользовательские функции, в которых используются операции VBA (Visual Basic для приложений) над ячейками, выполняемые в зависимости от фона или цвета шрифта. Вот пример подсчета количества ячеек определенного цвета с использованием VBA.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Источник: support.office.com

Функция СЧЕТЕСЛИ в Excel

В этой статье мы сосредоточимся на функции СЧЕТЕСЛИ в Excel, которая предназначена для подсчета ячеек с указанным вами условием. Во-первых, мы кратко рассмотрим синтаксис и общее использование, а затем приведем ряд примеров функции СЧЕТЕСЛИ.

По сути, функция СЧЕТЕСЛИ на английском COUNTIF, идентична во всех версиях Excel, поэтому вы можете использовать примеры из этого руководства в Excel 2016, 2013, 2010 и 2007.

Синтаксис и использование функции СЧЕТЕСЛИ в Excel

Функция СЧЕТЕСЛИ в Excel используется для подсчета ячеек в пределах заданного диапазона, которые соответствуют определенному критерию или условию.

Например, вы можете использовать функцию СЧЕТЕСЛИ, чтобы узнать, сколько ячеек на вашем листе содержит число больше или меньше указанного вами числа. Другое типичное использование функции СЧЕТЕСЛИ в Excel – подсчет ячеек с определенным словом или началом с конкретной буквы (букв).

Синтаксис функции СЧЕТЕСЛИ очень прост:

Как видите, есть только 2 аргумента функции СЧЕТЕСЛИ, оба из которых обязательны:

  • диапазон – определяет одну или несколько ячеек для подсчета. Вы помещаете диапазон в формулу, как обычно, в Excel, например. A1:A20.
  • критерии – определяет условие, которое сообщает функции, которую подсчитывают ячейки. Это может быть число, текстовая строка, ссылка на ячейку или выражение (например, “10”, A2, “>=10”).

Вот простейший пример функции СЧЕТЕСЛИ в Excel. Формула =СЧЁТЕСЛИ(C2:C7;”Иванов Иван”) подсчитывает, сколько заявок поступало от Иванова Ивана:

Функция СЧЕТЕСЛИ в Excel – Пример использования функции СЧЕТЕСЛИ в Excel

Примечание : Критерий нечувствителен к регистру, что означает, что если вы наберете «иванов иван» в качестве критерия в приведенной выше формуле СЧЕТЕСЛИ, это приведет к такому же результату.

Функция СЧЕТЕСЛИ в Excel – примеры

Синтаксис функции СЧЕТЕСЛИ очень прост, однако он допускает множество возможных вариантов критериев, включая подстановочные знаки, значения других ячеек и даже другие функции Excel.

Читайте также:  Excel двссыл

Функция СЧЕТЕСЛИ в Excel для текста и чисел (точное совпадение)

Выше мы рассмотрели пример функции СЧЕТЕСЛИ, которая подсчитывает текстовые значения, соответствующие определенному критерию.

Вместо ввода текста вы можете использовать ссылку на любую ячейку , содержащую это слово или слова, и получить абсолютно одинаковые результаты, например: =СЧЕТЕСЛИ(С1:С7; С2).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ со ссылкой на ячейку

Аналогичные формулы СЧЕТЕСЛИ работают для чисел , также как для текстовых значений.

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел

На изображении выше формула =СЧЁТЕСЛИ(B2:B7;10) учитывает ячейки с количеством 10 в столбце D.

Чтобы подсчитать ячейки со значениями больше, меньше или равными указанному вами числу, вы просто добавляете соответствующий логический оператор к критериям.

Обратите внимание, что в функции СЧЕТЕСЛИ оператор с числом всегда заключен в кавычки, например, =СЧЕТЕСЛИ(B2:B7; “>=10”).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел с логическим оператором

Функция СЧЕТЕСЛИ с подстановочными знаками (частичное совпадение)

Если данные Excel содержат несколько вариантов ключевых слов, которые вы хотите подсчитать, вы можете использовать подстановочный знак в функции СЧЕТЕСЛИ для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть содержимого ячейки.

Предположим, у вас есть список цветов, и вы хотите узнать количество цветов, в названии которых содержится слово “синий”. Поскольку эти цвета можно написать несколькими разными способами, мы вводим “*синий*” в качестве критериев поиска =СЧЕТЕСЛИ(B2:B8;”*синий*”).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с частичным совпадением

Звездочка (*) используется в функции СЧЕТЕСЛИ для поиска ячеек с любой последовательностью ведущих и конечных символов, как показано в приведенном выше примере. Если вам нужно сопоставить какой-либо один символ, введите вместо него знак вопроса (?) , например, =СЧЁТЕСЛИ(A2:A7;”ст?л”).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с подстановочным знаком

В данном случае функция СЧЕТЕСЛИ вернет значение 2, так как найдет «стол» и «стул».

Источник: naprimerax.org

Метод метод WorksheetFunction. СЧЁТЕСЛИ (Excel) WorksheetFunction.CountIf method (Excel)

Подсчитывает количество ячеек в диапазоне, соответствующих заданным условиям. Counts the number of cells within a range that meet the given criteria.

Синтаксис Syntax

Expression. Функция СЧЁТЕСЛИ (Arg1, arg2) expression.CountIf (Arg1, Arg2)

Expression (выражение ) Переменная, представляющая объект метод WorksheetFunction . expression A variable that represents a WorksheetFunction object.

Параметры Parameters

Имя Name Обязательный или необязательный Required/Optional Тип данных Data type Описание Description
Arg1 Arg1 Обязательный Required Range Range Диапазон ячеек, для которых необходимо подсчитать количество ячеек. The range of cells from which you want to count cells.
Arg2 Arg2 Обязательный Required Variant Variant Критерий в форме числа, выражения, ссылки на ячейку или текста, который определяет, какие ячейки будут подсчитаны. The criteria in the form of a number, expression, cell reference, or text that defines which cells will be counted. Например, критерий может быть выражен в виде 32, “32”, “>32”, “яблоки” или B4. For example, criteria can be expressed as 32, “32”, “>32”, “apples”, or B4.

Возвращаемое значение Return value

Double Double

Примечания Remarks

Для критериев можно использовать подстановочные знаки, вопросительный знак (?) и звездочку (*). You can use the wildcard characters, question mark (?) and asterisk (*), for the criteria. Вопросительный знак соответствует одному символу; Звездочка соответствует любой последовательности символов. A question mark matches any single character; an asterisk matches any sequence of characters. Если вы хотите найти фактический вопросительный знак или звездочку, введите тильду (

) перед символом. If you want to find an actual question mark or asterisk, type a tilde (

) before the character.

Поддержка и обратная связь Support and feedback

Есть вопросы или отзывы, касающиеся Office VBA или этой статьи? Have questions or feedback about Office VBA or this documentation? Руководство по другим способам получения поддержки и отправки отзывов см. в статье Поддержка Office VBA и обратная связь. Please see Office VBA support and feedback for guidance about the ways you can receive support and provide feedback.

Источник: docs.microsoft.com

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Функция СЧЕТЕСЛИ входит в группу статистических функций. Позволяет найти число ячеек по определенному критерию. Работает с числовыми и текстовыми значениями, датами.

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» – любой символ. «*» – любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (

).

  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.
  • 

    Функция СЧЕТЕСЛИ в Excel: примеры

    Посчитаем числовые значения в одном диапазоне. Условие подсчета – один критерий.

    У нас есть такая таблица:

    Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;”>100″). Диапазон – В1:В11. Критерий подсчета – «>100». Результат:

    Если условие подсчета внести в отдельную ячейку, можно в качестве критерия использовать ссылку:

    Посчитаем текстовые значения в одном диапазоне. Условие поиска – один критерий.

    Формула: =СЧЁТЕСЛИ(A1:A11;”табуреты”). Или:

    Во втором случае в качестве критерия использовали ссылку на ячейку.

    Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;”таб*”).

    Для расчета количества значений, оканчивающихся на «и», в которых содержится любое число знаков: =СЧЁТЕСЛИ(A1:A11;”*и”). Получаем:

    Формула посчитала «кровати» и «банкетки».

    Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

    Формула: =СЧЁТЕСЛИ(A1:A11;”<>“&”стулья”). Оператор «<>» означает «не равно». Знак амперсанда (&) объединяет данный оператор и значение «стулья».

    При применении ссылки формула будет выглядеть так:

    Часто требуется выполнять функцию СЧЕТЕСЛИ в Excel по двум критериям. Таким способом можно существенно расширить ее возможности. Рассмотрим специальные случаи применения СЧЕТЕСЛИ в Excel и примеры с двумя условиями.

    1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;”столы”)+СЧЁТЕСЛИ(A1:A11;”стулья”). Для указания нескольких условий используется несколько выражений СЧЕТЕСЛИ. Они объединены между собой оператором «+».
    2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция ищет в ячейке А1. Текст «стулья» – на базе критерия в ячейке А2.
    3. Посчитаем число ячеек в диапазоне В1:В11 со значением большим или равным 100 и меньшим или равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;”>=100″)-СЧЁТЕСЛИ(B1:B11;”>200″).
    4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это возможно, если диапазоны являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;”>=100″)-СЧЁТЕСЛИ(A1:B11;”>200″). Ищет значения по двум критериям сразу в двух столбцах. Если диапазоны несмежные, то применяется функция СЧЕТЕСЛИМН.
    5. Когда в качестве критерия указывается ссылка на диапазон ячеек с условиями, функция возвращает массив. Для ввода формулы нужно выделить такое количество ячеек, как в диапазоне с критериями. После введения аргументов нажать одновременно сочетание клавиш Shift + Ctrl + Enter. Excel распознает формулу массива.

    СЧЕТЕСЛИ с двумя условиями в Excel очень часто используется для автоматизированной и эффективной работы с данными. Поэтому продвинутому пользователю настоятельно рекомендуется внимательно изучить все приведенные выше примеры.

    ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

    Посчитаем количество реализованных товаров по группам.

    1. Сначала отсортируем таблицу так, чтобы одинаковые значения оказались рядом.
    2. Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ» – «Номер функции». Это числа от 1 до 11, указывающие статистическую функцию для расчета промежуточного результата. Подсчет количества ячеек осуществляется под цифрой «2» (функция «СЧЕТ»).

    Формула нашла количество значений для группы «Стулья». При большом числе строк (больше тысячи) подобное сочетание функций может оказаться полезным.

    Источник: exceltable.com

    Функция СЧЕТЕСЛИ в Excel и примеры ее использования

    Функция СЧЕТЕСЛИ входит в группу статистических функций. Позволяет найти число ячеек по определенному критерию. Работает с числовыми и текстовыми значениями, датами.

    Синтаксис и особенности функции

    Сначала рассмотрим аргументы функции:

    • Диапазон – группа значений для анализа и подсчета (обязательный).
    • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

    В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

    В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

    Рекомендации для правильной работы функции:

    • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
    • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
    • Функция не учитывает регистр текстовых значений.
    • При формулировании условия подсчета можно использовать подстановочные знаки. «?» – любой символ. «*» – любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (

    ).

  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.
  • 

    Функция СЧЕТЕСЛИ в Excel: примеры

    Посчитаем числовые значения в одном диапазоне. Условие подсчета – один критерий.

    У нас есть такая таблица:

    Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;”>100″). Диапазон – В1:В11. Критерий подсчета – «>100». Результат:

    Если условие подсчета внести в отдельную ячейку, можно в качестве критерия использовать ссылку:

    Посчитаем текстовые значения в одном диапазоне. Условие поиска – один критерий.

    Формула: =СЧЁТЕСЛИ(A1:A11;”табуреты”). Или:

    Во втором случае в качестве критерия использовали ссылку на ячейку.

    Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;”таб*”).

    Для расчета количества значений, оканчивающихся на «и», в которых содержится любое число знаков: =СЧЁТЕСЛИ(A1:A11;”*и”). Получаем:

    Формула посчитала «кровати» и «банкетки».

    Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

    Формула: =СЧЁТЕСЛИ(A1:A11;”<>“&”стулья”). Оператор «<>» означает «не равно». Знак амперсанда (&) объединяет данный оператор и значение «стулья».

    При применении ссылки формула будет выглядеть так:

    Часто требуется выполнять функцию СЧЕТЕСЛИ в Excel по двум критериям. Таким способом можно существенно расширить ее возможности. Рассмотрим специальные случаи применения СЧЕТЕСЛИ в Excel и примеры с двумя условиями.

    1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;”столы”)+СЧЁТЕСЛИ(A1:A11;”стулья”). Для указания нескольких условий используется несколько выражений СЧЕТЕСЛИ. Они объединены между собой оператором «+».
    2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция ищет в ячейке А1. Текст «стулья» – на базе критерия в ячейке А2.
    3. Посчитаем число ячеек в диапазоне В1:В11 со значением большим или равным 100 и меньшим или равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;”>=100″)-СЧЁТЕСЛИ(B1:B11;”>200″).
    4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это возможно, если диапазоны являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;”>=100″)-СЧЁТЕСЛИ(A1:B11;”>200″). Ищет значения по двум критериям сразу в двух столбцах. Если диапазоны несмежные, то применяется функция СЧЕТЕСЛИМН.
    5. Когда в качестве критерия указывается ссылка на диапазон ячеек с условиями, функция возвращает массив. Для ввода формулы нужно выделить такое количество ячеек, как в диапазоне с критериями. После введения аргументов нажать одновременно сочетание клавиш Shift + Ctrl + Enter. Excel распознает формулу массива.

    СЧЕТЕСЛИ с двумя условиями в Excel очень часто используется для автоматизированной и эффективной работы с данными. Поэтому продвинутому пользователю настоятельно рекомендуется внимательно изучить все приведенные выше примеры.

    ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

    Посчитаем количество реализованных товаров по группам.

    1. Сначала отсортируем таблицу так, чтобы одинаковые значения оказались рядом.
    2. Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ» – «Номер функции». Это числа от 1 до 11, указывающие статистическую функцию для расчета промежуточного результата. Подсчет количества ячеек осуществляется под цифрой «2» (функция «СЧЕТ»).

    Формула нашла количество значений для группы «Стулья». При большом числе строк (больше тысячи) подобное сочетание функций может оказаться полезным.

    Источник: exceltable.com

    Excel COUNTIF Function – How to Use

    As the name suggests Excel COUNTIF Function is a combination of Count and IF formula. In plain English, COUNTIF Function can be described as a formula that can be used for counting the number of cells that fulfill a particular condition, within a predefined range.

    How Excel Defines COUNTIF Function:

    Microsoft Excel defines COUNTIF as a formula that, “Counts the number of cells within a range that meet the given condition”.

    This definition clearly explains that: COUNTIF Function is a better and sophisticated type of COUNT formula that gives you the control over, which cells you wish to count.

    Syntax of Excel COUNTIF Formula:

    Excel COUNTIF formula can be written as follows:

    Here ‘ range ’ specifies the range of cells over which you want to apply the ‘ criteria ‘.

    ‘ criteria ’ specifies the condition that a particular cell content should meet to be counted.

    How to Use COUNTIF in Excel:

    Now, let’s see how to use COUNTIF function in Excel.

    Let’s consider, we have an Employee table as shown in the below image.

    Objective: From the above table, our objective is to find the number of employees who have joined before 1990.

    So, we will try to use the COUNTIF Formula to find the result.

    range: In this case, ‘ range ’ will be “B2:B11”, as on these cells we have to apply the ‘ criteria ’.

    criteria: In this case, ‘ criteria ’ is “ st January 1990.

    This results into 6, which means there are 6 employees that have joined before 1990.

    Few important facts about COUNTIF formula:

    1. COUNTIF formula only accepts a solid range, you cannot give multiple broken ranges to it. For example: COUNTIF cannot be written as =COUNTIF(A1:A4 , A6:A8, “>0”) . You must use a single range like =COUNTIF(A1:A8, “>0”) .

    2. COUNTIF can accept wildcard characters (like “*” and “?”) in the ‘ criteria ’ argument. This means that you can write a COUNTIF as =COUNTIF(D1:D15, “*o*”) . This will count all the cells containing “o” character, within the D1:D5 range.

    3. As you know, the output of COUNTIF is an integer so you can also add two COUNTIF functions. For example: if you want to find the cells with value as “1” and cells with value as “2”, so you can use COUNTIF as =COUNTIF(A1:A10,”1″)+COUNTIF(A1:A10,”2″) .

    4. COUNTIF throws a #NAME? error, if you supply an incorrect range to it .

    Few Basic Level Examples of COUNTIF Function:

    In the above image, I have used an Employee table to depict how COUNTIF function can be used.

    Example 1: In the first example, I have used Excel COUNTIF formula for finding the number of employees whose first name starts with “G”.

    For this I have used a formula as =COUNTIF(A3:A12,”G*”) .

    Here, the COUNTIF Function scans the whole range from A3:A12 and tries to find a pattern “G*” (‘*’ is a wildcard operator which denotes any number of characters). The resultant is 2, as there are only two persons in the specified range whose first name starts with G.

    Example 2: In the second example, I have used a COUNTIF function to find the cells which contain an Employee ID value greater than “26000”.

    To accomplish this I have used a formula =COUNTIF(C3:C12,”>26000″) .

    This formula searches the specified range for a value that specifies the criteria (i.e. >26000). So, the result is 5 as only 5 employees have an Employee ID greater than 26000.

    Example 3: In the third example, I have fetched the number of employees whose salary is less than 4000.

    To get this, I have again used a COUNTIF formula as =COUNTIF(D3:D12,” .

    So, here the COUNTIF counts only those cells where salary range i.e. D3:D12 has a value less than 4000 and the resultant is 3.

    Example 4: In the fourth example, I have used a formula =COUNTIF(B3:B12,B5) to find the number of cells equal to the value of the cell B5 (i.e. “Massiot”), in the range B3:B15.

    Here, first the COUNTIF function finds the value at B5 cell and then it compares all the cells within the specified range with this value.

    The resultant is 2 as only two records match the value at B5 cell.

    Example 5: In the above example, I had to find the total count of cells that contain “Apple” or “Peach”.

    This can be easily done by adding the resultants of two COUNTIF statements like: =COUNTIF(A2:A7,”Apple”)+COUNTIF(A2:A7,”Peach”) .

    The first COUNTIF statement gives the number of cells with value equal to “Apple” and the second statement gives the count of cells with “Peach”. And hence the output comes out as 2+1=3.

    Example 6: In this example (i.e. =COUNTIF(A,”Pear”) ), I have tried to show you what happens if you enter an incorrect range in COUNTIF function.

    In such cases it throws a #NAME? error.

    Few Advanced Examples of COUNTIF Function:

    Now, let’s see some practical examples of COUNTIF Function.

    Example 7: Finding duplicate values using COUNTIF function.

    Let’s say we have a table as below, and we have to find the duplicate records in it.

    For finding the duplicate records, we have used the formula: =COUNTIF($A$2:$A$16,A2)>1

    When this formula encounters a duplicate record it returns TRUE, while FALSE means that the record is Unique.

    If you are wondering what these dollar ($) signs are doing in this formula, then you should read this post.

    Example 8: Use COUNTIF formula for generating the sorting order of a list.

    Let’s consider we have a list as below.

    Now, If we just want to know the alphabetic sorting order (in ascending order) of the employee names, then we can use the formula: =COUNTIF($A$2:$A$15,”

    See the below image, to see this formula in action.

    As you can see, that this formula simply generates a number in-front of every employee. This number is the sorting order (in ascending sort) of the Employee Names.

    So, this was all from my side. Do share your ideas and experiences related to Excel COUNTIF Function in the below comments section.

    Ankit is the founder of Excel Trick. He is tech Geek who loves to sit in front of his square headed girlfriend (his PC) all day long. :D. Ankit has a strong passion for learning Microsoft Excel. His only aim is to turn you guys into ‘Excel Geeks’.

    Источник: www.exceltrick.com